Creando una VPN PPTP entre routers MikroTik

Introducción

PPTP (Point to Point Tunnel Protocol) es un túnel seguro (encriptado) que permite conectar diferentes dispositivos para realizar una VPN. MikroTik RouterOS soporta la implementación de un PPTP Server y cliente.

Las implementaciones típicas de PPTP son:

  • Acceso seguro router a router vía Internet
  • Acceso a un cliente el acceso a la red (usado en acceso a empleados de empresa para realizar el trabajo en su casa como si estuviera conectado a la Intranet)
  • Etc.

PPTP utiliza autenticación de usuario y contraseña. La conexión se realiza utilizando el puerto TCP 1723 y luego GRE (IP 47) para el encapsulado. Es necesario chequear estos puertos que estén aceptados en el firewall antes de realizar la implementación para que se pueda lograr el túnel.

Ejemplo

Se desea interconectar dos routers con PPTP, uno oficiará de Servidor (Office 1) y el otro de Cliente (Office 2):

PPTP Tunel

Datos Office 1:
IP Público: 200.200.200.1/24
IP Local: 10.10.10.1/24
IP PPTP local-address: 1.1.1.1
IP PPTP remote-address: 2.2.2.2

Datos Office 2:
IP Público: 100.100.100.1/24
IP Local: 10.20.20.1/24

Habilitando el PPTP Server en Office 1:

[admin@Office 1] /interface pptp-server server> set enabled=yes
[admin@Office 1] /interface pptp-server server> print
            enabled: yes
            max-mtu: 1460
            max-mru: 1460
               mrru: disabled
     authentication: mschap2
  keepalive-timeout: 30
    default-profile: default
[admin@Office 1] /interface pptp-server server>

Creando usuario en PPP secret en el server Office 1:
Usuario: Home – Password: 123

[admin@Office 1] /ppp secret> add name=Home service=pptp password=123
local-address=1.1.1.1 remote-address=2.2.2.2
[admin@Office 1] /ppp secret> print detail
Flags: X - disabled
  0   name="Home" service=pptp caller-id="" password="123" profile=default
      local-address=1.1.1.1 remote-address=2.2.2.2

[admin@Office 1] /ppp secret>

Creando la interface PPTP Client en Office 2:

[admin@Office 2] interface pptp-client> add connect-to=200.200.200.1 user=Home 
... password=123 disabled=no
[admin@Office 2] interface pptp-client> print
Flags: X - disabled, R - running
  0  R name="pptp-out1" mtu=1460 mru=1460 connect-to=200.200.200.1 user="Home"
       password="123" profile=default add-default-route=no

[admin@Office 2] interface pptp-client>

Si la configuración anterior está correctamente configurada lograremos conectar vía un túnel seguro el equipo cliente Office 2 hacía el Access Server Office 1 enviando una petición hacía el IP Público configurado. El router Office 2 al conectarse creará una interface dinámica PPTP Client y el IP colocado a la misma serán: IP: 2.2.2.2 Network: 1.1.1.1, el cual es un direccionamiento punto a punto. Luego podrá ser posible rutear las redes respectivas. Es recomendable utilizar diferentes direccionamiento de red.

Para testear la conexión es posible hacer ping entre los routers:

admin@Office 2]> /ping 1.1.1.1
1.1.1.1 pong: ttl=255 time=3 ms
1.1.1.1 pong: ttl=255 time=3 ms
1.1.1.1 pong: ttl=255 time=3 ms
ping interrupted
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 3/3.0/3 ms

Por: Maximiliano Dobladez
Bajo Licencia CC 2.5 – Attribution-Noncommercial-No Derivative